hive2.3版本编译异常

最近在编译hive2.3.9的时候遇到一个问题。
错误信息如下:

Could not transfer artifact org.apache.directory.client.ldap:ldap-client-api:pom:0.1-SNAPSHOT from/to central (http://repo1.maven.org/maven2/): transfer failed for http://repo1.maven.org/maven2/org/apache/directory/client/ldap/ldap-client-api/0.1-SNAPSHOT

原因是:丢失了依赖
解决方案:查看社区,发现存在一个issue。issue号是HIVE-21777

在/service/pom.xml增加依赖

<dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-server-integ</artifactId>
      <version>${apache-directory-server.version}</version>
      <scope>test</scope>
      <!-- 增加的依赖-->
        <exclusions>
        <exclusion>
        <groupId>org.apache.directory.client.ldap</groupId>
        <artifactId>ldap-client-api</artifactId>
    </exclusion>
    </exclusions>
    </dependency>

发表评论

邮箱地址不会被公开。